File:Link Aggregation1.JPG…and I thought this was simple.

Well, it was, after getting headed down the right path..   We decided to virtualize a few servers on a Dell™ PowerEdge™ R710.  One of the hosted servers is for a very bandwidth intensive application.  Thus the decision to aggregate the 4 Network interface cards (NIC) together using link aggregation.

The switch used in this instance is a Cisco 6513.

To get started, the first part of the set-up is to configure the Broadcom NICs.  This is done using the Broadcom Advanced Control Suite 3 (BACS).   The version of BACS that came installed on this server was somewhat dated.  It did not have the NIC teaming part of the software installed.   After heading over to Broadcom’s website, we updated both the network drivers and the BACS application.

I’ll spare you the screenshots in the install process..   but here is the end-result we’re looking for.

The key is to set the “Team Type” to Link Aggregation (802.3ad).

 

The cisco port settings that proved to work correctly:

!
interface GigabitEthernet13/5
no ip address
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 3 mode passive
!
interface GigabitEthernet13/6
no ip address
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 3 mode passive
!
interface GigabitEthernet13/7
no ip address
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 3 mode passive
!
interface GigabitEthernet13/8
no ip address
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 3 mode passive
!

…the PortChannel settings are as follow…

Current configuration : 141 bytes
!
interface Port-channel3
description VTHYPERV
no ip address
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
end

 

Please note, this configuration is designed to support 802.1q trunking to the server.   As we build virtual machines on the host server, we will have a need to place them on different VLANs.  This configuration may not be ideal for your application.  Consider placing the interfaces into access mode with the appropriate VLAN configured.